const regex = new RegExp('(^|[^\\.^\\d])0+(\\d)', 'gm')
const str = `02+03*04`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);