use strict;
my $str = '02+03*04';
my $regex = qr/(^|[^\.^\d])0+(\d)/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";