#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([gG][iI][rR] ?0[aA][aA])$|^((([a-zA-Z][0-9][0-9]?)|(([a-zA-Z][a-hA-Hj-yJ-Y][0-9][0-9]?)|(([a-zA-Z][0-9][a-zA-Z])|([a-zA-Z][a-hA-Hj-yJ-Y][0-9]?[a-zA-Z])))) ?[0-9][a-zA-Z]{2})$"
Local $sString = "AAA 1QG" & @CRLF & _
"gir 0aa" & @CRLF & _
"GIR0AA" & @CRLF & _
"gIR 0AA" & @CRLF & _
"giR 0AA" & @CRLF & _
"ig6 1qg" & @CRLF & _
"ig61qg" & @CRLF & _
"IG6 1QG" & @CRLF & _
"n22 5bp" & @CRLF & _
"n225bp" & @CRLF & _
"N22 5BP" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")