# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([gG][iI][rR] ?0[aA][aA])$|^((([a-zA-Z][0-9][0-9]?)|(([a-zA-Z][a-hA-Hj-yJ-Y][0-9][0-9]?)|(([a-zA-Z][0-9][a-zA-Z])|([a-zA-Z][a-hA-Hj-yJ-Y][0-9]?[a-zA-Z])))) ?[0-9][a-zA-Z]{2})$"
test_str = ("AAA 1QG\n"
"gir 0aa\n"
"GIR0AA\n"
"gIR 0AA\n"
"giR 0AA\n"
"ig6 1qg\n"
"ig61qg\n"
"IG6 1QG\n"
"n22 5bp\n"
"n225bp\n"
"N22 5BP\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.