re = /^([gG][iI][rR] ?0[aA][aA])$|^((([a-zA-Z][0-9][0-9]?)|(([a-zA-Z][a-hA-Hj-yJ-Y][0-9][0-9]?)|(([a-zA-Z][0-9][a-zA-Z])|([a-zA-Z][a-hA-Hj-yJ-Y][0-9]?[a-zA-Z])))) ?[0-9][a-zA-Z]{2})$/m
str = 'AAA 1QG
gir 0aa
GIR0AA
gIR 0AA
giR 0AA
ig6 1qg
ig61qg
IG6 1QG
n22 5bp
n225bp
N22 5BP
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end