use strict;
my $str = 'AAA 1QG
gir 0aa
GIR0AA
gIR 0AA
giR 0AA
ig6 1qg
ig61qg
IG6 1QG
n22 5bp
n225bp
N22 5BP
';
my $regex = qr/^([gG][iI][rR] ?0[aA][aA])$|^((([a-zA-Z][0-9][0-9]?)|(([a-zA-Z][a-hA-Hj-yJ-Y][0-9][0-9]?)|(([a-zA-Z][0-9][a-zA-Z])|([a-zA-Z][a-hA-Hj-yJ-Y][0-9]?[a-zA-Z])))) ?[0-9][a-zA-Z]{2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}