#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).(?=..\.TIF$)"
Local $sString = "VK1006_00_0010 00PLATE BEND 039333 0101116201 DE1 D 1.TIF" & @CRLF & _
"NB1022_01_5210 03PANHARD ROD 062193 010111- DH8 C01.TIF" & @CRLF & _
"TB1072_02_PLATE 01OOOOOD 89173001001 DC1.TIF" & @CRLF & _
"VA1056_01_1050 02TUBES 080129 010111- DA1 A01.TIF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")