const regex = /.(?=..\.TIF$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.(?=..\\.TIF$)', 'gm')
const str = `VK1006_00_0010 00PLATE BEND 039333 0101116201 DE1 D 1.TIF
NB1022_01_5210 03PANHARD ROD 062193 010111- DH8 C01.TIF
TB1072_02_PLATE 01OOOOOD 89173001001 DC1.TIF
VA1056_01_1050 02TUBES 080129 010111- DA1 A01.TIF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}