use strict;
my $str = 'VK1006_00_0010 00PLATE BEND 039333 0101116201 DE1 D 1.TIF
NB1022_01_5210 03PANHARD ROD 062193 010111- DH8 C01.TIF
TB1072_02_PLATE 01OOOOOD 89173001001 DC1.TIF
VA1056_01_1050 02TUBES 080129 010111- DA1 A01.TIF';
my $regex = qr/.(?=..\.TIF$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}