import Foundation
let pattern = #".(?=..\.TIF$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VK1006_00_0010 00PLATE BEND 039333 0101116201 DE1 D 1.TIF
NB1022_01_5210 03PANHARD ROD 062193 010111- DH8 C01.TIF
TB1072_02_PLATE 01OOOOOD 89173001001 DC1.TIF
VA1056_01_1050 02TUBES 080129 010111- DA1 A01.TIF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)