#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\|\|)(?!.*[$^.?*+()A-Z])[^\[\]\n]*(?:\[[^\[\]\n]*\][^\[\]\n]*)*[^\[\]\n]*$"
Local $sString = "abcdef [ghijk] lmn" & @CRLF & _
"abcdef [ghijk] [pqr lmn" & @CRLF & _
"abcdef [pqr [ghijk] lmn" & @CRLF & _
"abcde| [ghijk] lmn" & @CRLF & _
"abcde| [ghijk] | lmn" & @CRLF & _
"abcde|| [ghijk] lmn" & @CRLF & _
"abcde? [ghijk] lmn" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^(?!.*\[[^\]\n]*)[^$.|?*+()\n]*$" & @CRLF & _
"" & @CRLF & _
"There should be no Capital letter in string." & @CRLF & _
"String don't contains [^$.|?*+() with 2 exception. a. if there is [ in string then it will have to end with ] for example [test] is valid [test not valid, test] not valid [[test]] not valid etc. [test][test] can be valid." & @CRLF & _
"" & @CRLF & _
"^(?! [^\[\]\n]* (?:\[[^\[\]\n]*\][^\[\]\n]*)* \[ (?:\[[^\[\]\n]*\][^\[\]\n]*)*$)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")