use strict;
my $str = 'abcdef [ghijk] lmn
abcdef [ghijk] [pqr lmn
abcdef [pqr [ghijk] lmn
abcde| [ghijk] lmn
abcde| [ghijk] | lmn
abcde|| [ghijk] lmn
abcde? [ghijk] lmn
^(?!.*\\[[^\\]\\n]*)[^$.|?*+()\\n]*$
There should be no Capital letter in string.
String don\'t contains [^$.|?*+() with 2 exception. a. if there is [ in string then it will have to end with ] for example [test] is valid [test not valid, test] not valid [[test]] not valid etc. [test][test] can be valid.
^(?! [^\\[\\]\\n]* (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)* \\[ (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)*$)';
my $regex = qr/^(?!.*\|\|)(?!.*[$^.?*+()A-Z])[^\[\]\n]*(?:\[[^\[\]\n]*\][^\[\]\n]*)*[^\[\]\n]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}