$re = '/^(?!.*\|\|)(?!.*[$^.?*+()A-Z])[^\[\]\n]*(?:\[[^\[\]\n]*\][^\[\]\n]*)*[^\[\]\n]*$/m';
$str = 'abcdef [ghijk] lmn
abcdef [ghijk] [pqr lmn
abcdef [pqr [ghijk] lmn
abcde| [ghijk] lmn
abcde| [ghijk] | lmn
abcde|| [ghijk] lmn
abcde? [ghijk] lmn
^(?!.*\\[[^\\]\\n]*)[^$.|?*+()\\n]*$
There should be no Capital letter in string.
String don\'t contains [^$.|?*+() with 2 exception. a. if there is [ in string then it will have to end with ] for example [test] is valid [test not valid, test] not valid [[test]] not valid etc. [test][test] can be valid.
^(?! [^\\[\\]\\n]* (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)* \\[ (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)*$)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);