import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\|\\|)(?!.*[$^.?*+()A-Z])[^\\[\\]\\n]*(?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)*[^\\[\\]\\n]*$";
final String string = "abcdef [ghijk] lmn\n"
+ "abcdef [ghijk] [pqr lmn\n"
+ "abcdef [pqr [ghijk] lmn\n"
+ "abcde| [ghijk] lmn\n"
+ "abcde| [ghijk] | lmn\n"
+ "abcde|| [ghijk] lmn\n"
+ "abcde? [ghijk] lmn\n\n\n\n\n\n\n\n\n"
+ "^(?!.*\\[[^\\]\\n]*)[^$.|?*+()\\n]*$\n\n"
+ "There should be no Capital letter in string.\n"
+ "String don't contains [^$.|?*+() with 2 exception. a. if there is [ in string then it will have to end with ] for example [test] is valid [test not valid, test] not valid [[test]] not valid etc. [test][test] can be valid.\n\n"
+ "^(?! [^\\[\\]\\n]* (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)* \\[ (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)*$)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}