const regex = /^(?!.*\|\|)(?!.*[$^.?*+()A-Z])[^\[\]\n]*(?:\[[^\[\]\n]*\][^\[\]\n]*)*[^\[\]\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\|\\|)(?!.*[$^.?*+()A-Z])[^\\[\\]\\n]*(?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)*[^\\[\\]\\n]*$', 'gm')
const str = `abcdef [ghijk] lmn
abcdef [ghijk] [pqr lmn
abcdef [pqr [ghijk] lmn
abcde| [ghijk] lmn
abcde| [ghijk] | lmn
abcde|| [ghijk] lmn
abcde? [ghijk] lmn
^(?!.*\\[[^\\]\\n]*)[^\$.|?*+()\\n]*\$
There should be no Capital letter in string.
String don't contains [^\$.|?*+() with 2 exception. a. if there is [ in string then it will have to end with ] for example [test] is valid [test not valid, test] not valid [[test]] not valid etc. [test][test] can be valid.
^(?! [^\\[\\]\\n]* (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)* \\[ (?:\\[[^\\[\\]\\n]*\\][^\\[\\]\\n]*)*\$)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}