import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.{0,10}[^\\s\\S]*)";
final String string = "The quick brown from here is dope The quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dope";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}