// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.{0,10}[^\s\S]*)").unwrap();
let string = "The quick brown from here is dope The quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dope";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}