re = /^(.{0,10}[^\s\S]*)/
str = 'The quick brown from here is dope The quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dope'
# Print the match result
str.match(re) do |match|
puts match.to_s
end