$re = '/^(.{0,10}[^\s\S]*)/';
$str = 'The quick brown from here is dope The quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dope';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);