const regex = /^(.{0,10}[^\s\S]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{0,10}[^\\s\\S]*)', '')
const str = `The quick brown from here is dope The quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dopeThe quick brown from here is dope`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}