#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*%(?!([.]?[0-9]+)?[a-zA-Z]).*$"
Local $sString = "dsfdf (%) dsfgs %d s32523" & @CRLF & _
"%d %d % %t dsg" & @CRLF & _
"sfsf %d" & @CRLF & _
"dfsd %.464d, %353T"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")