$re = '/^.*%(?!([.]?[0-9]+)?[a-zA-Z]).*$/m';
$str = 'dsfdf (%) dsfgs %d s32523
%d %d % %t dsg
sfsf %d
dfsd %.464d, %353T';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);