import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*%(?!([.]?[0-9]+)?[a-zA-Z]).*$";
final String string = "dsfdf (%) dsfgs %d s32523\n"
+ "%d %d % %t dsg\n"
+ "sfsf %d\n"
+ "dfsd %.464d, %353T";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}