#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ip\s+route\s+([0-9|.]{7,15}\/\d{1,2})\s+([0-9|.]{7,15})\s+description\s+(.*?)$"
Local $sString = "ip route 10.8.125.144/28 10.0.59.5 description Sunny_House_HLR1_SIG" & @CRLF & _
"ip route 192.168.1.0/24 192.168.1.1 description D-link_DIR600M"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")