import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ip\\s+route\\s+([0-9|.]{7,15}\\/\\d{1,2})\\s+([0-9|.]{7,15})\\s+description\\s+(.*?)$";
final String string = "ip route 10.8.125.144/28 10.0.59.5 description Sunny_House_HLR1_SIG\n"
+ "ip route 192.168.1.0/24 192.168.1.1 description D-link_DIR600M";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}