// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ip\s+route\s+([0-9|.]{7,15}\/\d{1,2})\s+([0-9|.]{7,15})\s+description\s+(.*?)$").unwrap();
let string = "ip route 10.8.125.144/28 10.0.59.5 description Sunny_House_HLR1_SIG
ip route 192.168.1.0/24 192.168.1.1 description D-link_DIR600M";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}