package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ip\s+route\s+([0-9|.]{7,15}\/\d{1,2})\s+([0-9|.]{7,15})\s+description\s+(.*?)$`)
var str = `ip route 10.8.125.144/28 10.0.59.5 description Sunny_House_HLR1_SIG
ip route 192.168.1.0/24 192.168.1.1 description D-link_DIR600M`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}