re = /^ip\s+route\s+([0-9|.]{7,15}\/\d{1,2})\s+([0-9|.]{7,15})\s+description\s+(.*?)$/m
str = 'ip route 10.8.125.144/28 10.0.59.5 description Sunny_House_HLR1_SIG
ip route 192.168.1.0/24 192.168.1.1 description D-link_DIR600M'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end