#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[0-9]+(\.[0-9]{1,2})?( lakhs)?$"
Local $sString = "2 lakhs" & @CRLF & _
"3.4 lakhs" & @CRLF & _
"3.4"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)