use strict;
my $str = '2 lakhs
3.4 lakhs
3.4';
my $regex = qr/^[0-9]+(\.[0-9]{1,2})?( lakhs)?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";