re = /^[0-9]+(\.[0-9]{1,2})?( lakhs)?$/m
str = '2 lakhs
3.4 lakhs
3.4'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result