$re = '/^[0-9]+(\.[0-9]{1,2})?( lakhs)?$/m';
$str = '2 lakhs
3.4 lakhs
3.4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;