package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\!\s*(R|r)edirect:`)
var str = `! Redirect: Tells the adblocker to look for list updates from a new URL from that point on. To be used in the old file only (Not the new one), to avoid an infitite redirection loop
redirect:not()
redirect:has(
##redirect:
#?#redirect:
##moz-redirect:
redirect:contains(
! Redirect:
! redirect:
!Redirect:
!redirect:
! Redirect:
! redirect:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}