$re = '/^\!\s*(R|r)edirect:/m';
$str = '! Redirect: Tells the adblocker to look for list updates from a new URL from that point on. To be used in the old file only (Not the new one), to avoid an infitite redirection loop
redirect:not()
redirect:has(
##redirect:
#?#redirect:
##moz-redirect:
redirect:contains(
! Redirect:
! redirect:
!Redirect:
!redirect:
! Redirect:
! redirect:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);