# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\!\s*(R|r)edirect:"
test_str = ("! Redirect: Tells the adblocker to look for list updates from a new URL from that point on. To be used in the old file only (Not the new one), to avoid an infitite redirection loop\n"
"redirect:not()\n"
"redirect:has(\n"
"##redirect:\n"
"#?#redirect:\n"
"##moz-redirect:\n"
"redirect:contains(\n"
"! Redirect:\n"
"! redirect:\n"
"!Redirect:\n"
"!redirect:\n"
"! Redirect:\n"
"! redirect:")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.