const regex = /^\!\s*(R|r)edirect:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\!\\s*(R|r)edirect:', 'gm')
const str = `! Redirect: Tells the adblocker to look for list updates from a new URL from that point on. To be used in the old file only (Not the new one), to avoid an infitite redirection loop
redirect:not()
redirect:has(
##redirect:
#?#redirect:
##moz-redirect:
redirect:contains(
! Redirect:
! redirect:
!Redirect:
!redirect:
! Redirect:
! redirect:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}