#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d{0,3}(?:\.\d{0,2})?"
Local $sString = "1234567890.56566456465aa" & @CRLF & _
"1.000" & @CRLF & _
"456456" & @CRLF & _
"545 454" & @CRLF & _
"56465. 54645" & @CRLF & _
"655.468" & @CRLF & _
"65464.....465465" & @CRLF & _
"5.7" & @CRLF & _
"66.4" & @CRLF & _
"00.00" & @CRLF & _
"8.0" & @CRLF & _
"8.00" & @CRLF & _
"8.a" & @CRLF & _
"0.0" & @CRLF & _
"1.000" & @CRLF & _
"00001.1" & @CRLF & _
"546.54" & @CRLF & _
"4.9" & @CRLF & _
"9.999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")