import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d{0,3}(?:\\.\\d{0,2})?";
final String string = "1234567890.56566456465aa\n"
+ "1.000\n"
+ "456456\n"
+ "545 454\n"
+ "56465. 54645\n"
+ "655.468\n"
+ "65464.....465465\n"
+ "5.7\n"
+ "66.4\n"
+ "00.00\n"
+ "8.0\n"
+ "8.00\n"
+ "8.a\n"
+ "0.0\n"
+ "1.000\n"
+ "00001.1\n"
+ "546.54\n"
+ "4.9\n"
+ "9.999\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}