re = /^[1-9]\d{0,3}(?:\.\d{0,2})?/m
str = '1234567890.56566456465aa
1.000
456456
545 454
56465. 54645
655.468
65464.....465465
5.7
66.4
00.00
8.0
8.00
8.a
0.0
1.000
00001.1
546.54
4.9
9.999
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end