const regex = /^[1-9]\d{0,3}(?:\.\d{0,2})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]\\d{0,3}(?:\\.\\d{0,2})?', 'gm')
const str = `1234567890.56566456465aa
1.000
456456
545 454
56465. 54645
655.468
65464.....465465
5.7
66.4
00.00
8.0
8.00
8.a
0.0
1.000
00001.1
546.54
4.9
9.999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}