// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]\d{0,3}(?:\.\d{0,2})?").unwrap();
let string = "1234567890.56566456465aa
1.000
456456
545 454
56465. 54645
655.468
65464.....465465
5.7
66.4
00.00
8.0
8.00
8.a
0.0
1.000
00001.1
546.54
4.9
9.999
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}