#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:-|)(?:\d+|\d+\.\d+)(?:µs|ms|s|m|h))+$"
Local $sString = "300ms" & @CRLF & _
"-1.5h" & @CRLF & _
"2h45m" & @CRLF & _
"5m" & @CRLF & _
"30s" & @CRLF & _
"5µs" & @CRLF & _
"100" & @CRLF & _
"1 year" & @CRLF & _
"5M" & @CRLF & _
"30S" & @CRLF & _
"1Y"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")