using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:-|)(?:\d+|\d+\.\d+)(?:µs|ms|s|m|h))+$";
string input = @"300ms
-1.5h
2h45m
5m
30s
5µs
100
1 year
5M
30S
1Y";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}