re = /^(?:(?:-|)(?:\d+|\d+\.\d+)(?:µs|ms|s|m|h))+$/m
str = '300ms
-1.5h
2h45m
5m
30s
5µs
100
1 year
5M
30S
1Y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end