const regex = new RegExp('^(?:(?:-|)(?:\\d+|\\d+\\.\\d+)(?:µs|ms|s|m|h))+$', 'gm')
const str = `300ms
-1.5h
2h45m
5m
30s
5µs
100
1 year
5M
30S
1Y`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}