use strict;
my $str = '300ms
-1.5h
2h45m
5m
30s
5µs
100
1 year
5M
30S
1Y';
my $regex = qr/^(?:(?:-|)(?:\d+|\d+\.\d+)(?:µs|ms|s|m|h))+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}