#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)((?:#|0x)(?:[a-f0-9]{3}|[a-f0-9]{6})\b|(?:rgb|hsl)a?\([^\)]*\))"
Local $sString = "yo #5E81AC and there rgb(50, 186, 86) or even #1364e7 and rgb(242, 48, 84)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"style=\"color: rgb(255,0,24)\"" & @CRLF & _
"style=\"color: rgb(255, 0, 24)\"" & @CRLF & _
"style=\"color: rgba(255, 0, 24, .5)\"" & @CRLF & _
"style=\"color: hsla(170, 23%, 25%, 0.2 )\"" & @CRLF & _
"style=\"color: #fff\"" & @CRLF & _
"style=\"color: #f2ewq\" this isn\'t a color" & @CRLF & _
"style=\"color: #F2F2F2\"" & @CRLF & _
"style=\"color: 0x00ffff\" This is a color with the `#` escaped"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")