const regex = /((?:#|0x)(?:[a-f0-9]{3}|[a-f0-9]{6})\b|(?:rgb|hsl)a?\([^\)]*\))/gui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:#|0x)(?:[a-f0-9]{3}|[a-f0-9]{6})\\b|(?:rgb|hsl)a?\\([^\\)]*\\))', 'gui')
const str = `yo #5E81AC and there rgb(50, 186, 86) or even #1364e7 and rgb(242, 48, 84)
style=\\"color: rgb(255,0,24)\\"
style=\\"color: rgb(255, 0, 24)\\"
style=\\"color: rgba(255, 0, 24, .5)\\"
style=\\"color: hsla(170, 23%, 25%, 0.2 )\\"
style=\\"color: #fff\\"
style=\\"color: #f2ewq\\" this isn\\'t a color
style=\\"color: #F2F2F2\\"
style=\\"color: 0x00ffff\\" This is a color with the \`#\` escaped`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}