import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"((?:#|0x)(?:[a-f0-9]{3}|[a-f0-9]{6})\b|(?:rgb|hsl)a?\([^\)]*\))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
yo #5E81AC and there rgb(50, 186, 86) or even #1364e7 and rgb(242, 48, 84)
style=\"color: rgb(255,0,24)\"
style=\"color: rgb(255, 0, 24)\"
style=\"color: rgba(255, 0, 24, .5)\"
style=\"color: hsla(170, 23%, 25%, 0.2 )\"
style=\"color: #fff\"
style=\"color: #f2ewq\" this isn\'t a color
style=\"color: #F2F2F2\"
style=\"color: 0x00ffff\" This is a color with the `#` escaped
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)