use strict;
my $str = 'yo #5E81AC and there rgb(50, 186, 86) or even #1364e7 and rgb(242, 48, 84)
style=\\"color: rgb(255,0,24)\\"
style=\\"color: rgb(255, 0, 24)\\"
style=\\"color: rgba(255, 0, 24, .5)\\"
style=\\"color: hsla(170, 23%, 25%, 0.2 )\\"
style=\\"color: #fff\\"
style=\\"color: #f2ewq\\" this isn\\\'t a color
style=\\"color: #F2F2F2\\"
style=\\"color: 0x00ffff\\" This is a color with the `#` escaped';
my $regex = qr/((?:#|0x)(?:[a-f0-9]{3}|[a-f0-9]{6})\b|(?:rgb|hsl)a?\([^\)]*\))/uip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}